安全公告/【CVE-2020-22217】

基本信息

漏洞名称:
系统版本:Asianux
危险等级:中危
影响源码包:c-ares
CVSS_v3评分:5.9
修复版本:c-ares-1.16.1-7

漏洞描述

Buffer overflow vulnerability in c-ares before 1_16_1 thru 1_17_0 via function ares_parse_soa_reply in ares_parse_soa_reply.c.

修复方式

yum update PackageName

漏洞判定

执行命令yum info PackageName获取软件包版本号,版本小于修复版本,则受此漏洞影响,版本大于等于修复版本,则此漏洞已修复

补丁

参考

https://access.redhat.com/security/cve/CVE-2020-22217
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-22217
https://nvd.nist.gov/vuln/detail/CVE-2020-22217